OptiMail – Metrics Not Updating

Incident Report for Optimove Service

Resolved

OptiMail metrics processing has been restored for EU and US tenants.
Metrics for the last ~24 hours are recovering and updating as expected. We are continuing work to reconcile the remaining missing/delayed metrics from the incident window.
Posted Dec 28, 2025 - 12:05 UTC

Monitoring

A mitigation has been applied and OptiMail metrics processing has been restored for EU & US tenants.
Some customers may still see missing or delayed metrics for the period while we assess recovery/backfill options and continue monitoring system stability
Posted Dec 28, 2025 - 10:17 UTC

Investigating

We are investigating an issue causing OptiMail metrics to be missing or not updating for some customers in both EU and US regions, starting Dec 26, 2025 14:02 UTC.
This may impact Mission Control / OptiMail reporting visibility (e.g., recent campaign performance metrics). We are working to restore normal metrics processing and will provide updates as we learn more
Posted Dec 28, 2025 - 08:59 UTC
This incident affected: Campaigns Channels (Optimail).