UI - Optimove Site - Degraded Performance in Campaign Builder

Incident Report for Optimove Service

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 10:24 UTC

Monitoring

A fix has been implemented for the issue affecting campaign creation in the Campaign Builder. We are monitoring the results to ensure stability.
Posted Apr 10, 2026 - 10:05 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 10, 2026 - 08:49 UTC

Investigating

We are investigating an issue affecting the Campaign Builder, where some users may be unable to create campaigns. Our team is working to identify the root cause and restore normal functionality as quickly as possible.
Posted Apr 10, 2026 - 08:41 UTC
This incident affected: Europe (Core App) and USA (Core App).