A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2026 - 14:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2026 - 14:01 UTC
Update
We have identified the source of the issue leading to delays in campaign execution - Mitigation is in progress. Our team is working to restore normal service and will provide another update soon.
Posted Mar 17, 2026 - 13:37 UTC
Identified
We are currently experiencing an issue causing unexpected errors and delays in campaign execution.
What we’re doing- Our engineering team is actively investigating the root cause and working to restore normal execution as quickly as possible.
Next update- We will provide an update within 1–2 hours, or sooner if there are any significant developments.
Posted Mar 17, 2026 - 12:49 UTC
This incident affected: Europe (Batch Data Process) and USA (Batch Data Process).