EU - Delay in Campaign execution

Incident Report for Optimove Service

Resolved

This incident has been resolved.
Posted May 14, 2025 - 16:50 UTC

Monitoring

We are monitoring a fix released to address elevated errors in our Scheduled Campaign Execution.

Some tenants will experience delays in scheduled campaign execution as part of the batch process.
Posted May 14, 2025 - 14:37 UTC
This incident affected: Europe (Batch Data Process) and USA (Batch Data Process).