US | Batch Update Process - Delay in Campaign execution

Incident Report for Optimove Service

Resolved

This incident has been resolved.
Posted Jul 04, 2026 - 18:43 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 04, 2026 - 18:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 04, 2026 - 13:58 UTC

Update

We are continuing to investigate this issue.
Posted Jul 04, 2026 - 12:16 UTC

Investigating

We are currently experiencing errors leading to delays in campaign execution. As a result, some campaigns may remain in a “Not Run” status.
This typically occurs when the Batch Data Update is delayed and campaign execution starts later than scheduled, causing some campaigns to miss their designated run time.

What We’re Doing:
Our engineering team is actively investigating the root cause and working to restore normal execution as quickly as possible.

Recovery Options:
Manual Run:
For high-priority campaigns, you can run them manually via the Run Now feature in Mission Control. Hover over the relevant campaign or use the three-dot menu to access the option. https://academy.optimove.com/hc/en-us/articles/8649444827549-Using-Run-Now-Capability
Force Run:
If your instance has Force Run enabled, campaigns will still be delivered as part of the batch process if this incident is resolved within the grace period. https://academy.optimove.com/hc/en-us/articles/10701094593565-Using-Force-Run.
To enable Force Run, please reach out to your Customer Success Manager.

Next Update:
We will provide an update within 1–2 hours, or sooner if new information becomes available
Posted Jul 04, 2026 - 12:15 UTC
This incident affected: USA (Batch Data Process, Track & Trigger).