EU – Batch Update Process – Delays in Scheduled Campaign Processing

Incident Report for Optimove Service

Resolved

The issue causing campaign execution delays has been fully resolved. During the incident, some campaigns may have remained in a Not Run status. This can occur when the Batch Data Update is delayed and campaign execution begins later than scheduled, resulting in certain campaigns missing their designated run window.

Force Run Behavior
If your instance has Force Run enabled, affected campaigns may still be executed automatically as part of the batch process, provided the incident was resolved within the configured grace period. More details on Force Run can be found here:
https://academy.optimove.com/hc/en-us/articles/10701094593565-Using-Force-Run
To enable Force Run for your instance, please reach out to your Customer Success Manager.

Current Status
Campaign execution has stabilized, failure rates have returned to normal, and all systems are fully operational.
Posted Dec 27, 2025 - 10:11 UTC

Monitoring

Mitigation has been applied and Batch Update processing is recovering. We are monitoring until processing times return to normal. Some residual campaign execution delays may still be observed during recovery.
Posted Dec 27, 2025 - 09:14 UTC

Investigating

We are investigating delays in the Batch Update process affecting some EU tenants. As a result, scheduled campaigns may execute later than their configured time. Campaign execution will resume automatically once batch processing completes.
Posted Dec 27, 2025 - 09:01 UTC
This incident affected: Europe (Batch Data Process).