The issue affecting all Support email inboxes has been resolved. Email processing has resumed, and queued messages are being processed.
You may experience short-term delays as we work through the backlog. We do not expect further impact.
Thank you for your patience.
Posted Mar 03, 2026 - 12:20 UTC
Identified
We have identified the root cause of the issue affecting all Support email inboxes and are working with our service provider on remediation.
We expect the issue to be resolved within the next 45 minutes. Emails remain queued and will be processed once service is fully restored. Some response delays and potential SLA impact may occur.
For urgent matters, please continue using the Optimove Academy “Submit a request” form or the in-app /help widget.
We will provide confirmation once the issue is fully resolved.
Posted Mar 03, 2026 - 11:48 UTC
Update
Note: Emails are being queued and will be processed once service is restored. Some response delays and potential SLA impact may occur.
Posted Mar 03, 2026 - 10:21 UTC
Investigating
We’re currently investigating an issue where emails sent to our Support inbox are not being processed as expected, which may delay ticket creation and responses.
Workaround: Please submit your request via the Optimove Academy “Submit a request” form or use the in-app/help widget to reach our Support teams while we work to restore normal email processing.
Posted Mar 03, 2026 - 10:20 UTC
This incident affected: Europe (Core App) and USA (Core App).