The issue has been resolved and all services are operating normally. We will continue to monitor to ensure stability.
Posted Nov 04, 2025 - 14:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 04, 2025 - 13:32 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 04, 2025 - 13:05 UTC
Identified
We are working on a fix for an underlying infrastructure issue that is also causing delays in batch processing and campaign execution. Our team is actively addressing the problem and will provide another update as soon as more information becomes available.
Posted Nov 04, 2025 - 10:59 UTC
Investigating
We’re currently investigating an issue causing delays in Web & App Activity data processing for some tenants. As a result, audiences that use web and app attributes may be temporarily affected. Other systems continue to operate normally.
Posted Nov 04, 2025 - 10:10 UTC
This incident affected: USA (Batch Data Process, Track & Trigger) and Europe (Track & Trigger).