EU - Batch Update Process - Delay in Campaign execution

Incident Report for Optimove Service

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 09:11 UTC

Monitoring

We have Identified and working on recovering from elevated errors in our batch update process. The system is now functional and operational however there is a live recovery effort that might impact Campaign execution times.

Some tenants will experience delays in scheduled campaign execution as part of the batch process.
Posted Jul 10, 2025 - 07:48 UTC
This incident affected: Europe (Batch Data Process).