EU – Batch Update Process – Delays in Scheduled Campaign Processing

Incident Report for Optimove Service

Resolved

This incident has been resolved.
Posted Jan 05, 2026 - 17:25 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 05, 2026 - 13:39 UTC

Investigating

We are investigating delays in the Batch Update process affecting some EU tenants. As a result, scheduled campaigns may execute later than their configured time. Campaign execution will resume automatically once batch processing completes.
Posted Jan 05, 2026 - 12:57 UTC
This incident affected: Europe (Batch Data Process).