The issue affecting campaign execution in the EU environment has been resolved.
Note: Some scheduled campaigns may remain in a “Not Run” status. This occurs when the batch data update is delayed and campaign execution starts later than scheduled, causing certain campaigns to miss their designated run time.
Recovery Options: - For campaigns that remained in a “Not Run” status, users may leverage the “Run Now” option in Mission Control. - Accounts with Force Run enabled may have campaigns processed within the defined grace period. - Alternatively, you may reach out to our Support team if you require assistance running affected campaigns in bulk.
We appreciate your patience and understanding.
Posted Feb 17, 2026 - 14:42 UTC
Monitoring
Campaign processing queues in the EU environment are decreasing and performance is gradually improving.
We are continuing to investigate the root cause, including potential third-party dependencies, while closely monitoring the system.
We will provide further updates as more information becomes available.
Posted Feb 17, 2026 - 12:26 UTC
Identified
We have identified the root cause of the campaign execution delays in the EU environment.
Ou team is actively working to restore normal processing as quickly as possible.
We will continue to provide updates as progress is made.
Posted Feb 17, 2026 - 10:37 UTC
Investigating
We are currently experiencing errors causing delays in campaign execution in the EU environment.
Workaround: For time-sensitive campaigns, users may leverage the “Run Now” option in Mission Control. Accounts with Force Run enabled will process campaigns if the issue is resolved within the defined grace period.
Our engineering team is actively investigating and working to restore normal processing.
Posted Feb 17, 2026 - 10:18 UTC
This incident affected: Europe (Batch Data Process) and USA (Batch Data Process).