Optimove Site - UI - Some users are no able to load pages in the site - Empty page
Incident Report for Optimove Service
Resolved
This incident has been resolved.
Posted May 21, 2024 - 12:50 UTC
Monitoring
A fix has been implemented - we are monitoring the results.
Posted May 21, 2024 - 11:48 UTC
Investigating
We are investigating an issue affecting the Optimove site. Some users cannot navigate the site and are loading empty pages.
This incident is limited to UI and site functionality.

Daily process, Campaign execution and API access is fully functional and unaffected.
Posted May 21, 2024 - 10:31 UTC
This incident affected: Europe (Core App) and USA (Core App).