Batch Update Process - Delay in Campaign execution

Incident Report for Optimove Service

Resolved

This incident has been resolved.
Posted Jun 06, 2026 - 12:52 UTC

Monitoring

A fix has been applied, and the affected daily data update process is now showing signs of recovery.

We are currently re-initiating previously failed batch updates in a controlled manner to avoid creating additional load. Some customers may continue to experience delays while these updates are being processed.

Next Steps:
We are continuing to resume the affected batch update processes and monitor their successful completion.

Next Update:
We will provide another update within 1–2 hours, or sooner if normal operation is fully restored.
Posted Jun 06, 2026 - 06:36 UTC

Investigating

We are currently experiencing errors leading to delays in the daily data update process for some instances. As a result, campaigns scheduled to run after the daily update may be delayed or may remain in a “Not Run” status.

This issue affects only some instances using the impacted daily update workflow. Instances using other daily update workflows are not affected.

This typically occurs when the daily data update process after the ETL phase is delayed or fails, preventing campaign execution from starting as scheduled and causing some campaigns to miss their designated run time.

What We’re Doing:
Our engineering team is actively investigating the root cause and working to restore normal execution as quickly as possible.

Recovery Options:
Manual Run:
For high-priority campaigns, you can run them manually via the Run Now feature in Mission Control. Hover over the relevant campaign or use the three-dot menu to access the option:
https://academy.optimove.com/hc/en-us/articles/8649444827549-Using-Run-Now-Capability

Force Run:
If your instance has Force Run enabled, campaigns will still be delivered as part of the batch process if this incident is resolved within the grace period:
https://academy.optimove.com/hc/en-us/articles/10701094593565-Using-Force-Run

To enable Force Run, please reach out to your Customer Success Manager.

Next Update:
We will provide an update within 1-2 hours, or sooner if new information becomes available.
Posted Jun 06, 2026 - 04:19 UTC
This incident affected: Europe (Batch Data Process) and USA (Batch Data Process).