Scheduled Campaign Execution – Degraded Performance

Incident Report for Optimove Service

Resolved

The issue impacting scheduled campaign execution has been resolved and systems are operating normally. Campaign batch processing and execution for Conditional Execution, Re-evaluate Target Group, and “Run Now” campaigns are now working as expected.

Some campaigns that missed their execution window during the incident may still show a "Not Run" or "Failed" status. In these cases, customers can re-run the campaign from the Optimove platform to execute it.
Posted Dec 30, 2025 - 14:30 UTC

Update

Campaign batch processing is operating normally.
We are still monitoring issues impacting campaigns using Conditional Execution, Re-evaluate Target Group, and “Run Now”, which may continue to experience delays or show “Failed” / “Not Run” status.

Further updates will be provided as we continue to work toward full resolution.
Posted Dec 30, 2025 - 13:30 UTC

Update

We observed degradation impacting scheduled campaign execution and have rolled out an additional fix.
Campaign processing is ongoing, and some delays or “Failed” / “Not Run” statuses may still be observed for campaigns using Conditional Execution, Re-evaluate Target Group, and “Run Now”.

We are closely monitoring recovery.
Posted Dec 30, 2025 - 12:43 UTC

Update

We continue to monitor recovery. While batch processing remains active, we are still observing additional issues that may impact campaigns using Conditional Execution, Re-evaluate Target Group, and “Run Now”. Some delays or “Failed” / “Not Run” statuses may still occur. Further updates will be shared as progress continues.
Posted Dec 30, 2025 - 12:34 UTC

Update

We continue to monitor recovery. Some delays may still be observed for campaigns using Conditional Execution, Re-evaluate Target Group, and “Run Now”.

For campaigns showing a “Not Run” status, re-running the campaign from the Optimove platform is available.
Posted Dec 30, 2025 - 11:20 UTC

Monitoring

A fix has been applied and scheduled campaign batches are progressing, though some delays have already occurred.
We are still seeing issues impacting campaigns using Conditional Execution, Re-evaluate Target Group, and “Run Now”, which may continue to appear as delayed or show “Failed” / “Not Run” status. We are monitoring closely and continuing to work toward full resolution.
Posted Dec 30, 2025 - 10:41 UTC

Investigating

We are investigating an issue impacting scheduled campaign execution in both EU and US regions. Campaigns using Conditional Execution, Re-evaluate Target Group, or “Run Now” may be delayed and may remain in “Processing” or appear as “Failed” / “Not Run”. This may impact deliveries via Optimove native channels (e.g., Optimail, Optimobile, OptiText). We are working to restore normal processing.
Posted Dec 30, 2025 - 10:06 UTC
This incident affected: Europe (Batch Data Process) and USA (Batch Data Process).